# Table of Contents

Using the ANGEL 8.0 HTML Editor ................................................................. 3  
Accessing the Menus ......................................................................................... 3  
Using the Toolbar and Menus ......................................................................... 4  
Formatting Text ................................................................................................ 4  
Editing Text ....................................................................................................... 13  
Creating and Using Macros .............................................................................. 17  
Inserting Hyperlinks .......................................................................................... 21  
Working with Tables .......................................................................................... 29  
Using Images, Flash Presentations, and Movies .............................................. 31  
Working with Forms ........................................................................................... 40  
Working with the Equation Editor .................................................................... 49  
Using the Insert Menu ....................................................................................... 51  
Using Other Tools .............................................................................................. 54  
Customizing Content Templates ....................................................................... 55  
Customizing Styles ........................................................................................... 56  
Shortcut Keys .................................................................................................... 57
Using the ANGEL 8.0 HTML Editor

This guide is designed to provide instructors, students, and mentors with an understanding of the HTML editor. ANGEL's HTML editor is a full "What You See Is What You Get" (WYSIWYG) editor specifically designed to work within the ANGEL learning management system. The editor is present in any place where text can be formatted or edited.

Notable features include the following:

- Full WYSIWYG editing everywhere you can edit content within ANGEL.
- Simple menu options allow you to find and link to any other content item within your course or on the web.
- The Insert Image tool features an integrated file/web browser with the capability to select a graphic, seamlessly upload it to the course, and then insert the graphic into the document.
- Content template support allows for the creation of course content with a consistent look and feel.
- Integrated equation editor from industry leader WebEQ.
- Full table support makes it easier to present complex tabular data.
- You can paste from a plain text editor directly into your HTML editor. Note: Microsoft Word is not a plain text editor. Copying from Word can bring over invalid script which may interfere with the application causing unexpected behavior.
- Edit window automatically resizes as you enter text, allowing the window to start small and expand dynamically as you add text.

The following typographical conventions are used in this guide:

- **Bold** indicates window elements such as field names, window titles, and buttons.
- **Italics** indicate words or characters you type into a field.

The following abbreviations are used:

- N indicates the Normal view of the content item editor.
- A indicates the Advanced view of the content item editor.

Accessing the Menus

The HTML editor is a toolbar containing a menu of tools that will help you to enhance your pages within ANGEL. The editor has three modes that are implemented to best support the user's current task:

- **Full menu.** The menu bar with all 32 menu features active.
- **Partial menu.** The menu bar with 16 menu features active. Available in ANGEL's Announcement Editor, Page Banner, Data Management nugget, Page Folder, Institutional Resource nugget, Did You Know nugget, About This Section nugget, Course News and Events nugget, and Syllabus nugget.
- **Slim menu.** The menu bar with 13 menu features active; available in ANGEL's Calendar feature.

The HTML Editor toolbar includes the following tools. (The table after the figure describes the tools, using the matching letters from the figure. The full menu includes all the menus/tools; the partial and slim menus show fewer or different varieties of the menus/tools.)

<table>
<thead>
<tr>
<th>Letter</th>
<th>Menu/Tool</th>
<th>Description</th>
<th>Partial Menu</th>
<th>Slim Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>a</td>
<td>Maximize HTML Editor</td>
<td>Maximizes the HTML editor toolbar.</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>b</td>
<td>Edit/Macro</td>
<td>Allows you to create and edit macros.</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>c</td>
<td>Edit/Paste menu</td>
<td>Allows you to cut, copy, paste, paste from Microsoft Word, paste as plain text, find/replace text, select all text, or remove formatting.</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Font Style menu</td>
<td>Allows you to use bold, underline, italic, strikethrough, superscript, and subscript in text.</td>
<td>Bold, italic and underline only</td>
<td>Bold, italic and underline only</td>
</tr>
<tr>
<td>---</td>
<td>----------------</td>
<td>---------------------------------------------------------------------------------</td>
<td>-------------------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>e</td>
<td>Link menu</td>
<td>Allows you to enter content and web links, remove links, and create anchors.</td>
<td>Content link, web link only</td>
<td>Content link, web link only</td>
</tr>
<tr>
<td>f</td>
<td>Media menu</td>
<td>Allows you to insert and format images, movies, and Flash presentations. Includes Google Media™ integration.</td>
<td>Images</td>
<td>Images</td>
</tr>
<tr>
<td>g</td>
<td>Insert menu</td>
<td>Allows you to use an HTML widget, create and modify equations, insert special characters, use the Universal Keyboard, and insert lines and page breaks.</td>
<td>Equation editor and special characters only</td>
<td>Equation editor only</td>
</tr>
<tr>
<td>h</td>
<td>Table menu</td>
<td>Allows you to manipulate rows, columns, and cells.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>i</td>
<td>Form menu</td>
<td>Allows you to create forms using elements such as buttons, text fields, and form parameters.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>j</td>
<td>List menu</td>
<td>Allows you to add bullets, numbering, and indents.</td>
<td>Numbered and bulleted only</td>
<td>Numbered and bulleted only</td>
</tr>
<tr>
<td>k</td>
<td>Justify menu</td>
<td>Allows you to position your text as left-aligned, right-aligned, centered, or block justified.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>l</td>
<td>Text &amp; Background Color menu</td>
<td>Allows you to change your text and background colors.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>m</td>
<td>Formatting &amp; Styles menu</td>
<td>Allows you to change your styles, fonts, and font size; and format your text.</td>
<td>Font and size only</td>
<td>Font and size only</td>
</tr>
<tr>
<td>n</td>
<td>Spell Checker</td>
<td>Allows you to spell check your text.</td>
<td>Spell check only</td>
<td>Spell check only</td>
</tr>
<tr>
<td>o</td>
<td>View Source</td>
<td>Allows you to view the HTML source for your document.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Caution:** You need to disable pop-up blocking features to use some tools in the HTML editor. Failing to disable pop-up blocking may result in loss of information in the HTML editor and failure of the HTML editing features.

### Using the Toolbar and Menus

Before you can begin using the HTML editor, you need to be able to access the menus. To access a menu, click the down arrow to expand the menu; then click the tool (e.g., cut, copy, paste, web link, etc.).

To access a tool, do one of the following:
- Click the tool icon in the toolbar.
- Click the down arrow to expand the menu; then click the tool (e.g. cut, copy, paste, web link, etc.).

### Formatting Text

You can format text and paragraphs as you would use a word processor: to add visual organization, emphasis, and structure. You can change the font, size, style, and color; and add effects such as underlining. You can also control indentation, add bullets and numbers, and set alignment.

The formatting you apply can either affect selected words or an entire paragraph. A general rule is that font properties (such as font, size, color, and effects) can be applied to selected text, and paragraph properties (including alignment, bullets, numbering, and formatting) affect entire paragraphs. For example, you can italicize a single word in a paragraph, but if you try to align a word to the right, the entire paragraph will be aligned.

The editing tools give you the ability to copy, cut, and paste words, sentences, and paragraphs as plain text or with full formatting.
Formatting Individual Characters and Words

You can set the following properties for words or characters.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bold</td>
<td>Bold accentuates the text.</td>
</tr>
<tr>
<td>Italic</td>
<td>Italic causes the text to slant.</td>
</tr>
<tr>
<td>Underline</td>
<td>Underline places a line under the text.</td>
</tr>
<tr>
<td>Strike Through</td>
<td>Strikethrough places a line through the text.</td>
</tr>
<tr>
<td>Superscript</td>
<td>Superscript places the text slightly higher than other text on a line, such as a footnote reference mark.</td>
</tr>
<tr>
<td>Subscript</td>
<td>Subscript places the text slightly lower than other text on a line. Subscripts are often used in scientific formulas.</td>
</tr>
<tr>
<td>Color</td>
<td>Color allows you to affect the color of text.</td>
</tr>
<tr>
<td>Background color</td>
<td>Background color allows you to add highlighting to selected text.</td>
</tr>
<tr>
<td>Style</td>
<td>Style is a set of predefined formatting instructions that you can use repeatedly throughout the document.</td>
</tr>
<tr>
<td>Font</td>
<td>Font affects how text appears on a page. Font will default to the browser's default, usually Times New Roman or Times (on a Mac).</td>
</tr>
<tr>
<td>Size</td>
<td>Font Size affects the size of the text on a page.</td>
</tr>
</tbody>
</table>

Applying Boldface

To apply bold formatting, follow these steps:
1. Select the text you want to change.
2. Do one of the following:
   - Click **Bold**.
   - On the **Font Style** menu, select **Bold**.

Applying Italics

To apply italic formatting, follow these steps:
1. Select the text you want to change.
2. Do one of the following:
   - Click **Italic**.
   - On the **Font Style** menu, select **Italic**.
Applying Underline

To apply underline formatting, follow these steps:

1. Select the text you want to change.
2. Do one of the following:
   - Click **Underline**.
   - On the **Font Style** menu, select **Underline**.

Applying Strikethrough

To apply strikethrough formatting, follow these steps:

1. Select the text that you want to change.
2. On the **Font Style** menu of the toolbar, select **Strike Through**.

Applying Superscript and Subscript

To apply superscript text formatting, follow these steps:

1. Select the text that you want to change.
2. On the **Font Style** menu of the toolbar, select **Superscript**.

To apply subscript text formatting, follow these steps:

1. Select the text that you want to change.
2. On the **Font Style** menu of the toolbar, select **Subscript**.

Changing the Text Style

To apply a different text style, follow these steps:

1. Select the text you want to change.
2. Click the **Style** icon.
3. Select the style you want.

**Note:** The Style properties contain both character and paragraph styles. To apply the style to only the selected text, select a style with the word **Text** in the title.

Changing the Font

To change the font, follow these steps:

1. Select the text you want to change.
2. Click **Font**. In the drop-down list, a right arrow points to the current font.
3. Select the font you want.
Changing the Point Size

To change the point size, follow these steps:
1. Select the text you want to change.
2. Click **Size**.
3. Select the font size you want.

Changing Text and Background Colors

The text color properties affect the color of text. These properties can be applied to a specific character or a whole page.

To change the color of text, follow these steps:
1. Select the text you want to change.
2. Click **Text Color**.
3. Click the color you want.
   - If you did not select text in step 1, your chosen text color will apply to items typed from this point onward.

To change the background color of text, follow these steps:
1. Select the text you want to change.

2. Click **Background Color**.

3. Click the color you want.
   
   If you did not select text in step 1, your chosen text color will apply to items typed from this point onward.

![Color Palette]

**Tip:** You can select more colors by clicking **More Colors,** finding the color you want, and clicking it. Once you've selected a color, it will show in the **Highlighted** box only until you click **OK.** To clear the selected color from within the **Select Color** dialog box, click **Clear.**

---

### Formatting Paragraphs

Following are the properties that you can set for paragraphs.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="icon" alt="Increase Indent" /></td>
<td>Indents determine the distance of the paragraph from the left or right margin.</td>
</tr>
<tr>
<td><img src="icon" alt="Decrease Indent" /></td>
<td></td>
</tr>
<tr>
<td><img src="icon" alt="Left Justify" /></td>
<td>Left or right justify determines the appearance and orientation of the edges of the paragraph: left-aligned, right-aligned, centered, or justified. (Justify: to adjust horizontal spacing so that text is aligned at both the left and right margins.)</td>
</tr>
<tr>
<td><img src="icon" alt="Center Justify" /></td>
<td></td>
</tr>
<tr>
<td><img src="icon" alt="Right Justify" /></td>
<td></td>
</tr>
<tr>
<td><img src="icon" alt="Block Justify" /></td>
<td></td>
</tr>
<tr>
<td><img src="icon" alt="Format" /></td>
<td>Format allows you to select preselected text and heading format options from a drop-down list.</td>
</tr>
</tbody>
</table>

---

### Indenting Paragraphs

Indents determine the distance of the paragraph from the left margin.

To increase the left indent, follow these steps:

1. Place the insertion point into the paragraph you want to change.

2. On the **List** menu, select **Increase Indent**.
To decrease the left indent, follow these steps:

1. Place the insertion point into the paragraph you want to change.
2. On the List menu, select Decrease Indent.

Aligning Paragraphs Horizontally on the Page

To left-align text, follow these steps:

1. Place the insertion point into the paragraph you want to align to the left of the page.
2. On the Justify menu, select Left Justify.

To right-align text, follow these steps:

1. Place the insertion point into the paragraph you want to align to the right of the page.
2. On the Justify menu, select Right Justify.

To center text, follow these steps:

1. Place the insertion point into the paragraph you want to align to the center of the page.
2. Click Center Justify.

To block-align text, follow these steps:

1. Place the insertion point into the paragraph you want to align along both the left and right margins.
2. Click the arrow on the Justify menu; select Block Justify.

Inserting Line Breaks

A line break ends the current line and continues the text on the next line of the same paragraph.

To insert a line break, follow these steps:

1. Place the insertion point where you want to create a new line.
2. Press Shift-Enter.

Applying Paragraph Styles

To choose a paragraph format, follow these steps:

1. Place the insertion point into the paragraph you want to format.
2. Click Format.
3. Click the text format you want.
Using Bulleted, Numbered, and Multilevel Lists

You can add bullets or numbers to existing lines of text, or you can automatically create bulleted and numbered lists as you type. Numbered lists display a sequential series of items. Bulleted lists display a series of unordered items.

Numbered Lists

Numbered lists display a sequential list of items. You can select from upper- and lowercase letters, numbers, or upper- and lowercase Roman numerals. Following are examples of each type of list.

Here’s a lettered list:
   a. Do this first.
   b. Do this second.
   c. Do this third.

Here’s a numbered list:
   1. Do this first.
   2. Do this second.
   3. Do this third.

Here’s a Roman numeral list:
   i. Do this first.
   ii. Do this second.
   iii. Do this third.

To create a numbered list, follow these steps:
1. Place the insertion point at the target location.
2. Click Insert/Remove Numbered List.
3. Type the text you want to add next to the number and then press Enter.
4. To end the list, press Enter again.

To create a numbered list using existing text, follow these steps:
1. Do one of the following:
   ● Select the items to which you want to add numbering.
   ● Place the insertion point at the target location.
2. Click Insert/Remove Numbered List.
3. To end the list, press Enter again.

To format a numbered list, follow these steps:
1. Right-click any item in the numbered list you want to change.
2. In the pop-up menu, click Numbered List Properties.
   The Numbered List Properties dialog box appears.
3. Type the number to start the list in the **Start** box.
4. Select the number format you want from the **Type** drop-down list.
5. Click **OK**. (Click **Cancel** if you decide to exit the dialog box without making changes.)

To remove a numbered list, follow these steps:
1. Select the text from which you want numbers removed.
2. Click **Insert/Remove Numbered List**.

**Tip:** To remove a single number, click the number and then press **Backspace**.

**Bulleted Lists**

Bulleted lists are used to present a list of unordered items (items that don't need to be numbered). You can select from circle (filled circle), disc (hollow circle), or square bullets.

To create a bulleted list, follow these steps:
1. Place the insertion point at the target location.
2. Click **Insert/Remove Bulleted List**.
3. Type the text you want to add next to the bullet and then press **Enter**.
4. To end the list, press **Enter** again.

To create a bulleted list using existing text, follow these steps:
1. Do one of the following:
   - Select the items to which you want to add bullets.
   - Place the insertion point at the target location.
2. Click **Insert/Remove Bulleted List**.
3. To end the list, press **Enter** again.

To format a bulleted list, follow these steps:
1. Right-click any item in the bulleted list you want to change.
2. In the pop-up menu, click **Bulleted List Properties**.

   The **Bulleted List Properties** dialog box appears.
3. Select the list format you want from the **Type** drop-down list.
4. Click **OK**. (Click **Cancel** if you decide to exit the dialog box without making changes.)

To remove a bulleted list, follow these steps:

1. Select the text from which you want bullets removed.
2. Click **Insert/Remove Bulleted List**.

   **Tip:** To remove a single bullet, click the bullet and then press **Backspace**.

---

**Multilevel Lists**

You can create lists that have multiple nested levels and specify different list formats for each level. For example, you may want to create lists that use different numbering styles at each level.

To create a multilevel list, follow these steps:

1. Place the insertion point at the target location.
2. Click either **Insert/Edit Numbered List** or **Insert/Edit Bulleted List**.
3. For each item you want in the list, regardless of its level, type the item, and then press **Enter**.
4. When you have typed the last item, press **Enter** twice to end the list.
5. To place each item on the correct level, do one of the following:
   - To move items down to the next level, select the items and then click **Increase Indent**.
   - To move items up to the previous level, select the items and then click **Decrease Indent**.

6. To apply list formats to the different levels, do one of the following:
   - To format a numbered list, follow these steps:
     a. Right-click any item in the list you want to change.
     b. In the pop-up menu that appears, click **Numbered List Properties**.
c. In the **Numbered List Properties** dialog box that appears, type the number to start the list in the **Start** box.

![Numbered List Properties](image)

d. Select the number format you want from the **Type** drop-down list.

e. Click **OK**.

- **To format a bulleted list,** follow these steps:
  a. Right-click any item in the list you want to change.
  b. In the pop-up menu that appears, click **Bulleted List Properties**.

![Bulleted List Properties](image)

c. In the **Bulleted List Properties** dialog box that appears, select the list format you want from the **Type** drop-down list.

![Bulleted List Properties](image)

d. Click **OK**.

### Removing Formatting

To remove all formatting, follow these steps:

1. Select the text from which you want to remove formatting.

2. On the **Edit/Paste** menu, select **Remove Format**.

### Editing Text

The **Edit/Paste** menu is used to make changes to your text. Using the same type of features as a word processing program, you can do the following:

- Undo or redo an action.
- Cut, copy, or paste sections of text and images.
- Paste text as plain text or with Word formatting.
- Find, replace, or select all text.
- Remove formatting from text.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Undo allows you to undo the most recent action taken.</td>
</tr>
<tr>
<td>Redo</td>
<td>Redo allows you to redo the most recent action taken.</td>
</tr>
<tr>
<td>Cut</td>
<td>Cut allows you to remove the highlighted text.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copy allows you to copy the highlighted text.</td>
</tr>
<tr>
<td>Paste</td>
<td>Paste pastes the text you copied (with or without formatting).</td>
</tr>
<tr>
<td>Paste as plain text</td>
<td>Paste as plain text allows you to remove formatting from text before pasting it into the text area.</td>
</tr>
<tr>
<td>Paste from Word</td>
<td>Paste from Word allows you to paste text from Microsoft Word into the HTML editor, retaining the exact replica of the Word document. You should always use this option when copying from Word.</td>
</tr>
<tr>
<td>Find</td>
<td>Find allows you to find specific words or phrases for editing or deletion.</td>
</tr>
<tr>
<td>Replace</td>
<td>Replace allows you to replace words or phrases with new wording.</td>
</tr>
<tr>
<td>Select All</td>
<td>Select All allows you to select the entire text to format.</td>
</tr>
<tr>
<td>Remove Format</td>
<td>Remove Format allows you to remove all formatting from text.</td>
</tr>
</tbody>
</table>

**Undoing and Redoing Actions**

Undo reverses the last action you performed in the HTML editor. Undo has a twin feature called Redo. You can undo 15 levels of actions.

- Click the arrow on the **Edit/Paste** menu and select **Undo**.

Redo reverses the last Undo action. If you accidentally undo too many actions, Redo puts them back into your page. You can redo 15 levels of actions.

- Click the arrow on the **Edit/Paste** menu and select **Redo**.

**Cutting, Copying, and Pasting**

To cut (remove) text, follow these steps:

1. Select text you want to cut.
2. On the **Edit/Paste** menu, select **Cut**.

To copy text, follow these steps:

1. Select text you want to cut.
2. On the **Edit/Paste** menu, select **Copy**.

To paste text, follow these steps:
1. **Cut** or **Copy** the item you want to paste.

2. Reposition the insertion point at the target location.

3. On the **Edit/Paste** menu, select **Paste**.

   If the text contains formatting from Word, you will receive a message "The text you want to paste seems to be copied from Word. Do you want to clean it before posting?"

   If the text contains formatting from non-Word applications, the HTML editor will copy the formatting when the item is pasted.

### Pasting as Plain Text

To paste in plain text format, follow these steps:

1. **Cut** or **Copy** the item you want to **Paste**.

2. Reposition the insertion point at the target location.

3. On the **Edit/Paste** menu, select **Paste**.

### Pasting from Microsoft Word

To paste text from Word, follow these steps:

1. **Cut** or **Copy** the item you want to **Paste**.

2. Reposition the insertion point at the target location.

3. On the **Edit/Paste** menu, select **Paste from Word**.

   The **Paste from Word** dialog box displays.

4. Do you want to clean the text before posting? If yes, paste your text in the box provided.
   a. Check **Ignore Font Face definitions** to remove the Word font styles.
   b. Check **Remove Styles definitions** to remove the Word formatting styles.

5. Click **OK**. Your text is pasted from Word, applying the Word styles and formatting.
Finding and Replacing Text

To find text, follow these steps:

1. On the Edit/Paste menu, select Find.
2. In the Find dialog box that displays, complete the following fields:
   a. **Find what.** The text you want to search for.
   b. **Match case.** Match the case format.
   c. **Match whole word.** Match the full word(s). Ignores partial matches.
3. Click Find.
4. Click Cancel to close the dialog box.

To replace text, follow these steps:

1. On the Edit/Paste menu, select Replace.
2. On the Replace dialog box that displays, complete the following fields:
   a. **Find what.** The text you want to search for.
   b. **Replace with.** The replacement text.
   c. **Match case.** Match the case format.
   d. **Match whole word.** Match the full word(s). Ignores partial matches.
3. Click Replace or Replace All.
4. Click Cancel to close the dialog box.
**Selecting All Text**

To select all text, follow these steps:

1. On the **Edit/Paste** menu, choose **Select All**.

**Creating and Using Macros**

Macros are preprogrammed shortcuts that perform a series of actions. Macros can be created and shared across courses, groups, and resource libraries to which you have editor access. The creation of macros allows you to create the item once and use it multiple times in your courses, groups, or resource libraries.

For example, if you want to automatically insert a salutation (e.g., Hello class!) at the beginning of each page, you can create a macro that allows you to insert the phrase (instead of having to retype it for every page).

After your macro has been created, you can use it on the page you are creating or share it in other courses, groups, or resource libraries to which you have editing rights.

The **Insert/Edit Macro** tool allows you to create or edit shortcuts that perform a series of actions.

To create a new macro, follow these steps:

1. Click **Insert/Edit Macro**.
2. Click the **New Macro** tab.
3. In the **New Macro** tab, complete the following fields:

   a. **Name**. The name of your macro.
   b. **Category**. The category for the macro. Do one of the following to define the category:
      - Choose the category from the drop-down list.
      - Click the **New Macros** button to create a new category.
   c. **Macro text**. The text to be inserted into the text area when the macro is played. The formatting of the text requires HTML tags.
4. Click **Save**.

To edit a macro, follow these steps:

1. Click **Insert/Edit Macro**.
2. On the **Macro** dialog box, select the category from the drop-down list.
3. Select the macro you want to edit and click **Edit**.
4. On the **Existing Macros** tab, do the following:
   
   a. Update the name, category, and macro text as necessary.
   b. Click **Save**.

   ![Note: To apply the updated macros to your new page, you will need to use the **Insert a Macro** function. You cannot paste HTML from the editor window.](image)

**Inserting Macros**

To insert a macro, follow these steps:

1. Click **Insert/Edit Macro**.
2. On the **Macro** dialog box that displays, follow these steps:
a. Select the **Category** from the drop-down list.
b. Click the macro you want to insert from the category on the left side of the window.
c. Click the **OK** button.

**Deleting Macros**

To delete a macro, follow these steps:

1. Click **Insert/Edit Macro**.
2. On the **Macro** dialog box, do the following:
a. Select the category from the drop-down list.

b. Click the macro you want to delete.

c. Click Delete. You are prompted with the following: Permanently delete this item? Click OK to delete the macros from your list and from the Category options, or click Cancel to return to the Existing Macros tab.

d. Click the OK button.

**Sharing Macros**

To share a macro, follow these steps:

1. Click Insert/Edit Macro.

2. On the Macro dialog box, select the Category from the drop-down list. Your list of macros from that category is listed in the text area on the left side.

3. Select the macro you want to share.

4. Click Share. The Macro dialog box displays.
5. Complete the following fields:
   a. **Share with.** The minimum course rights required to use the shared macro.
   b. **In these sections.** The course/group section to share the macro with.

6. Click **Save.**

**Inserting Hyperlinks**

A hyperlink is a link from one page or file to another. On a page, you may want to insert a hyperlink to some other website or to a document you uploaded to your server. A hyperlink is usually displayed by a distinguishing feature such as a different color, font, or style. When a hyperlink is clicked, the destination is displayed, opened, or run—depending on the type of destination. The destination is frequently another page, but it can also be a picture, a multimedia file, a document, an e-mail address, or a program.

To create, edit, and remove hyperlinks, you use the tools found on the **Link** menu.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Web Link" /></td>
<td>Insert/Edit Web Link. Adds or removes hyperlink from highlighted text. Used to add or edit links outside the ANGEL environment or an anchor within a page.</td>
</tr>
<tr>
<td><img src="image" alt="Content Links" /></td>
<td>Insert Content Link creates links to areas in the system where links exist or will exist based on an upload.</td>
</tr>
<tr>
<td><img src="image" alt="Remove Link" /></td>
<td>Remove Link allows you to remove a hyperlink you've inserted in a page.</td>
</tr>
<tr>
<td><img src="image" alt="Anchor" /></td>
<td>Anchor allows you to create bookmarks within pages inside and outside of ANGEL.</td>
</tr>
</tbody>
</table>
Web Links

A web link is used to create a reference or navigation element to another section of the same page, to an e-mail or to another page on the Internet.

To create a link to a web address (URL), follow these steps:

1. Select the text or image you want to use as the hotspot for the link.

2. Click Web Link. The Link dialog box displays.

3. On the Link Info tab, complete the following fields:
   a. **Link Type.** Specifies the link type (e.g., URL, Link to anchor in the text, E-mail). For a web link to a page on the Internet, select URL.
   b. **Protocol.** Specifies the protocol from the drop-down list (e.g., http, https, ftp, news, other).
   c. **URL.** Specifies the URL or address of the web page the link will display.

4. Click the Target tab.
5. Optionally complete the following fields:
   a. **Target Type.** Select the target type from the drop-down list:
      - Frame: A frame within the current frame.
      - Pop-up Window: Opens in a pop-up window.
      - New Window: Opens in a new window.
      - Topmost Window: Opens in topmost window which replaces your current window.
      - Same Widow: Opens in the same window you are using.
      - Parent Window: Opens in new window unless you are in frames.
   b. **Target Frame Name.** When using the target type of frame, this specifies the name of the frame the target displays.

6. Click the **Advanced** tab.
7. Optionally complete the following:

- **Id.** Creates an anchor at the start tag of any HTML element (HTML id attribute).
- **Language Direction.** Specifies the base direction of directionally neutral text. Possible values include the following:
  - Left-to-right
  - Right-to-left
- **Access Key.** A single character that defines the shortcut key (Alt + character) that "clicks" on the link.
- **Name.** The anchor name that links to an anchor within a page.
- **Language Code.** Specifies the base language of the target URL.
- **Tab Index.** Defines the position in tabbing order.
- **Advisory Title.** Defines the text that displays when the user moves the mouse over the link.
- **Advisory Content Type.** Gives an advisory hint about the content type of the target URL. Examples include text/html, image/png, image/gif, video/mpeg, text/css, etc.
- **Stylesheet Classes.** Assigns a class name or set of class names to an element.
- **Linked Resource Charset.** Specifies the character encoding of the target URL.
- **Style.** Allows entry of custom CSS style information for the element.

8. Click **OK**.

To create a link to an e-mail address, follow these steps:

1. Click **Web Link**.
2. On the **Link Info** tab, select **E-Mail** from the **Link Type** list.
3. Complete the following fields:
   a. **E-Mail Address**. The recipient’s e-mail address.
   b. **Message Subject**. The subject of the message to be sent.
   c. **Message Body**. The information to be contained in the message body.

4. Click the **Advanced** tab.

5. Optionally complete the following:
   - **Id**. Creates an anchor at the start tag of any HTML element (HTML Id attribute).
   - **Language Direction**. Specifies the base direction of directionally neutral text. Possible values include the following:
• Left-to-right
• Right-to-left

• **Access Key.** A single character that defines the shortcut key (Alt + character) that "clicks" the link.
• **Name.** The anchor name that links to an anchor within a page.
• **Language Code.** Specifies the base language of the target URL.
• **Tab Index.** Defines the position in tabbing order.
• **Advisory Title.** Defines the text that displays when the user mouses over the link.
• **Advisory Content Type.** Provides gives an advisory hint as to the content type of the target URL. Examples include ext/html, image/png, image/gif, video/mpeg, text/css, etc.
• **Stylesheet Classes.** Assigns a class name or set of class names to an element.
• **Linked Resource Charset.** Specifies the character encoding of the target URL.
• **Style.** Allows entry of custom CSS style information for the element.

6. Click **OK.**

To edit web links, follow these steps:

1. Right-click the hyperlink and click **Edit Link.**

To remove web links, follow these steps:

1. Select the hyperlink you want to remove.
2. Do one of the following:
   • On the **File** menu, select **Remove Link.**
   • Click the **Insert/Edit Content Link** button. In the **URL** box, highlight the URL and press **Delete.**
   • Right-click the hyperlink and click **Remove Link.**

### Content Links

A content link is used to create a reference or navigation element to an item within the ANGEL LMS environment. There are five different areas which you can link to from a course.

<table>
<thead>
<tr>
<th>Content Area</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Personal Files</td>
<td>Allows you to link to files stored in your personal file manager (within the Toolbox, select Personal Home page &gt; Files link). This is useful for users who want to link to the same file resource from multiple courses or locations. This approach is not recommended when building a master course image that will be used by multiple instructors because the source image would be deleted in the event the instructor's account is ever deleted from the system.</td>
</tr>
<tr>
<td>Associated Files</td>
<td>Displays all file resources (html page, images, PowerPoint, Adobe .pdf, etc.) uploaded to the current content item. This is the recommended location for file resources if the content item needs to remain portable, meaning that the content item (quiz, page, folder, etc.) needs to support export to a different course or location as is commonly the case with content items in learning object repositories. When a content item is exported or copied from another course, all file resources for the content item are exported/copied as well.</td>
</tr>
<tr>
<td>Course Files</td>
<td>Displays the root view of all associated files for all content items in the course. This option can be helpful when dealing with multiple content items that need to the same file resources within the course (i.e., repeated course images, etc.). File resources within the Course File Manager are always exported with the course, but are not included when importing/exporting a single content item (i.e., from a repository). Therefore, this approach can be effective for individual instructor courses and master courses, but should not be used to store file resources for repository content items.</td>
</tr>
<tr>
<td>Map</td>
<td>Displays a birds-eye view of the course content, course tabs, and select course tools/reports, allowing the editor to create links to specific content items, tools, or tabs. If HTML anchors exist in the page item or an uploaded web page, the appropriate syntax (i.e., #anchor1) can be added to the end of the resultant link to provide direct navigation to that portion of the course.</td>
</tr>
</tbody>
</table>
To insert content links, follow these steps:

1. Do one of the following:
   - Select **Insert Content Link**.
   - On the **Link** menu, select **Content Links**.

2. On the **Content Links** dialog box, do the following:
   - Choose the tab for which you need to upload files.
   - Click **New Folder** to create a new folder if applicable.

3. On the tab(s) you selected, do one of the following:
   - Click **Browse** and select a file (available for personal, associated or course only). Then click **Upload File**.
   - In the **Path** box, select an existing file, map path, or icon. Your link will be inserted into the HTML editor window.

To edit content links, follow these steps:

1. Right-click the hyperlink and click **Edit Link**.
2. On the **Content Links** dialog box, edit the hyperlink properties.
3. Click **OK**.

To remove content links, do the following:

1. Select the hyperlink you want to remove.
2. Do one of the following:
   - On the **File** menu, select **Remove Link**.
   - Click the **Insert/Edit Content Link**. In the **URL** box, highlight the URL and press **Delete**.
   - Right-click the hyperlink and click **Remove Link**.

**Using Anchors**

An essential feature of a web page is the ability to connect (hyperlink) pages, media files, and programs. A hyperlink can be made from one resource to another or from one location within a resource to another. Both the source and the destination of a link are anchors (sometimes called bookmarks).

For example, you may have a page with several topics. At the end of each topic, you may want to include an anchor that, when clicked, will bring users back to the top of a topic or back to the table of contents.

Creating an anchor is a two-step process. First, you create an anchor and then create a link to the anchor.

When creating an anchor, naming it is very important. The name is an opportunity to remember for what purpose you created it. In the preceding example, you might name your anchor **top**, which signifies that by clicking the anchor, you will be returned to the top of a page or section.

Some other tips for naming your anchors are as follows:

- Create short, one-word names.
To add an anchor, follow these steps:

1. Position the insertion point at the target location.
2. On the **File** menu, select **Anchor**. The **Anchor Properties** dialog box displays.

3. In the **Anchor Properties** dialog box, type the **Anchor Name**. The anchor icon will appear at the anchor point.

To insert a link to an anchor, follow these steps:

1. Select the text or image you want to use as the hotspot for the link.
2. Click **Web Link**.
3. On the **Link** tab, select **Link to anchor in the text** from the **Link Type** list.

4. Complete one of the following fields:
- Select an Anchor By Anchor Name.
- Select an Anchor By Element Id.

5. Click **OK**.

### Working with Tables

A table is made up of columns and rows of cells into which you can insert text and graphics. There are several different ways to use tables, and you can customize your tables in a variety of ways to make them more attractive and easy to read.

The Tables tool allows you to arrange data such as text, images, links, forms, and so on into columns and rows of cells.

### Creating a Table and Setting Table Properties

To create a table and set table properties, follow these steps:

1. Position the insertion point where you want to insert the table.
2. Do one of the following:
   - Click **Insert/Edit Table**.
   - Click the Table menu and select **Insert/Edit Table**. The **Table Properties** dialog box displays.
     
     ![Table Properties Dialog](image)

3. Complete the following:
   a. **Rows**. Specifies the number of rows.
   b. **Columns**. Specifies the number of columns.
   c. **Alignment**. Specifies the position for the table on the page.
   d. **Width**. Specifies the width of the table in either pixels or as a percentage of the window width.
   e. **Height**. Specifies the height of the table in pixels.
   f. **Border size**. Specifies the width you want for the table border in pixels. If you do not want a border, type 0.
   g. **Cell spacing**. Specifies a number in the Cell padding box.
   h. **Cell padding**. Specifies a number in the Cell spacing box.
   i. **Caption**. Specifies a caption in the Caption box.
j. **Summary.** Specifies a summary of the table for use with speech-synthesizing/nonvisual browsers, if applicable.

4. Click **OK**.

Tip: When a table is present on your page, you can right-click in the table and a pop-up menu displays with possible table operations.

### Setting Cell Properties

Tables are composed of cells, and each cell can be formatted by using cell properties.

To set the properties of a table cell, follow these steps:

1. Select the cells you want to change.
2. Right-click and then click **Cell > Cell Properties** on the pop-up menu. The **Cell Properties** dialog box displays.

![Cell Properties -- Web Page Dialog](image)

3. Complete the following fields:
   
   a. **Width.** Specifies the size of the cell width in either pixels or as a percent.
   
   b. **Height.** Specifies the size of the cell height in pixels.
   
   c. **Word Wrap.** Allows text to wrap in a cell.
   
   d. **Horizontal Alignment.** Specifies the horizontal position for the text within the cell.
   
   e. **Vertical Alignment.** Specifies the vertical position for the text within the cell.
   
   f. **Rows Span.** Specifies the number of rows you want the cells to span.
   
   g. **Columns Span.** Specifies the number of columns you want the cells to span.
   
   h. **Background Color.** Specifies the color background.
   
   i. **Border Color.** Specifies the border color of tables.

4. Click **OK**.

### Adding Cells, Rows, and Columns

To insert cells, follow these steps:

1. Position the insertion point in a cell to the left of where you want to add a cell.

2. On the **Table** menu of the toolbar, select **Insert Cell**.
To insert rows, follow these steps:
1. Position the insertion point in a cell above where you want to add a new row.
2. On the Table menu of the toolbar, select Insert Row.

To insert columns, follow these steps:
1. Position the insertion point in a cell to the left of where you want to add a new column.
2. On the Table menu of the toolbar, select Insert Column.

To insert tables within tables, follow these steps:
1. Position the insertion point in a cell where you want to add a new table.
2. Do one of the following:
   - Click Insert/Edit Table.
   - On the Table menu of the toolbar, select Table.

To split cells, follow these steps:
1. Position the insertion point in the cell you want to divide.
2. Right-click the cell and then click Cells > Split Cells on the pop-up menu.

To merge cells, follow these steps:
1. Select the cells you want to combine.
2. Right-click the selection and then click Cells > Merge Cells on the pop-up menu.

**Deleting All or Part of a Table**

To delete a table, follow these steps:
1. Select the cells you want to delete.
2. Right-click and select Delete Table on the pop-up menu.

To delete a cell, follow these steps:
1. Select the cells you want to delete.
2. On the Table menu of the toolbar, select Delete Cells.

To delete a row, follow these steps:
1. Select the rows you want to delete.
2. On the Table menu of the toolbar, select Delete Rows.

To delete a column, follow these steps:
1. Select the columns you want to delete.
2. On the Table menu of the toolbar, select Delete Columns.

**Using Images, Flash Presentations, and Movies**

In the HTML editor, you can add images, Flash presentations, and movies. These elements visually enhance your pages as well as provide rich content for a variety of audiences and learning types.

You can use images on your page for a variety of reason. In addition to being decorative, graphics can be useful in providing information, examples or even navigational buttons.

The Media menu contains the following tools.
<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Image" /></td>
<td>Inserts an image (.jpg, .tiff, .bmp, and so on).</td>
</tr>
<tr>
<td><img src="flash" alt="Flash" /></td>
<td>Inserts a Flash presentation file.</td>
</tr>
<tr>
<td><img src="movie" alt="Movie" /></td>
<td>Inserts a movie file (.MP3, AU, AVI, WMV, etc.)</td>
</tr>
<tr>
<td><img src="google_media" alt="Google Media" /></td>
<td>Google Media™ allows you to search Google™ images and YouTube™ videos for inclusion in your documents.</td>
</tr>
</tbody>
</table>

**Using Images**

Images are a good way to make your content more visual. Images can include elements such as logos, line art, and simple graphics. There are several image formats that can be used on the Internet. The following are the most common:

- **.gif.** GIF (Graphics Interchange Format) is an 8-bit-per-pixel bitmap image format that was introduced by CompuServe in 1987 and has since come into widespread usage on the World Wide Web due to its wide support and portability. The format uses a palette of up to 256 distinct colors. It also supports animations and allows a separate palette of 256 colors for each frame.

- **.jpg.** JPEG (Joint Photographic Experts Group) provides for lossy compression of images. The file format is typically used for high-end images or photographs. The format uses a palette of 16.7 million colors.

- **.png.** PNG (Portable Network Graphics) is a bitmapped image format that employs lossless data compression. PNG was created to improve and replace the GIF format as an image-file format not requiring a patent license. The format uses a palette of 24-bit RGB colors or grayscale.

To add an image, follow these steps:

1. Position your cursor where you want to insert the image.
2. Do one of the following
   - Click the **Insert/Edit image** ![Image](image).
   - On the **Media** menu, select **Image** ![Image](image). The **Image Properties** dialog box displays.
3. On the **Image Properties** dialog box, complete the **Image Info** tab:
   a. **URL.** The web address of the image to display. Click **Browse Server** to navigate to the image location.
   b. **Alternative Text.** Used by web browsers to display text during image downloads for users who have graphics turned off and for users who rely on screen-reading software to convert graphics on the screen to spoken words.
   c. **Width.** Sets the width of an image. Can be entered in pixels or as a percentage.
   d. **Height.** Sets the height of an image. Can be entered in pixels or as a percentage.
   e. **Lock Ratio.** Select to lock image aspect ratio (relationship of the height and width of an image). When selected, resizing with the height or width automatically maintains the ratio of the other.
   f. **Reset Size.** Select to reset the image to its original size.
   g. **Border.** The size of the border in pixels around the graphic. This is a way to indicate that the graphic can be clicked.
   h. **HSpace.** Defines white space, in pixels, on the left and right side of the image.
   i. **VSpace.** Defines white space, in pixels, on the top and bottom of the image.
   j. **Align.** Specifies how to align the image according to surrounding text.
      - **Left.** Aligns the image to be left justified. Text will begin at the top of right of the image.
      - **Abs Bottom.** Aligns the bottom of the first line of text with the bottom of the image.
      - **Abs Middle.** Aligns the top of the first line of text with the middle of the image.
      - **Baseline.** Aligns the bottom of the image with the baseline of the text. The baseline is the line along which the bottom of most letters rest but below which some letters dangle, such as j and y.
      - **Bottom.** Aligns the bottom of the image with the baseline of the line containing the image.
      - **Middle.** Aligns the center of the image with the bottom of the first text line.
      - **Right.** Aligns the image to be right justified. Text will start at the top left of the image.
• **Text Top.** Aligns the first line of text with the top of the image.
• **Top.** Aligns the top of the image with the tallest item on the line containing the image.

4. If the image to be used as a hyperlink, click the **Link** tab.

5. On the **Link** tab, complete the following:
   a. **URL.** The web address of the link to display when the image is clicked. Click **Browse Server** to navigate to the link page.
   b. **Target.** Select the target from the drop-down list.
   c. **New Window (_blank):** Opens in a new window.
   d. **Topmost (_top):** Opens in topmost window which replaces your current window.
   e. **Same Window (_self):** Opens in the same window as the image.
   f. **Parent Window (_parent):** Opens in new window.

6. Optionally, click the **Advanced** tab.
7. Optionally, complete the following:
   a. **Id.** Creates an anchor at the start tag of any HTML element (HTML Id attribute).
   b. **Language Direction.** Specifies the base direction of directionally neutral text. Possible values are the following:
      - **Left-to-right**
      - **Right-to-left**
   c. **Language Code.** Specifies the base language of the target URL.
   d. **Long Description URL.** Specifies the URL of a document that contains an extended description of the resource.
   e. **Stylesheet Classes.** Assigns a class name or set of class names to an element.
   f. **Advisory Title.** Defines the text that displays when the user mouses over the link.
   g. **Style.** Allows entry of custom CSS style information for the element.
8. Click **OK**. (Click **Cancel** if you decide to exit the dialog box without making changes.)

**Using Flash**

Flash refers to both the Adobe Flash Player and to a multimedia authoring program used to create content (such as web applications, games, and movies). Flash presentations are a good way to add interactive content to your pages.

To add a Flash presentation, follow these steps:

1. Position your cursor where you want to insert the Flash presentation.

2. On the **Media** menu, select **Flash**. The **Flash Properties** dialog box displays.
3. On the Flash Properties dialog box Info tab, complete the following fields:
   a. **URL.** Specifies a web address of the Flash file. Click the Browse Server button to navigate to the file if it is located in the course or is to be uploaded to the course.
   b. **Width.** Specifies the width to display the Flash presentation in pixels.
   c. **Height.** Specifies the height to display the Flash presentation in pixels.

   **Tip:** You can preview your Flash file in the Preview pane.

4. Click the Advanced tab.
5. Optionally, complete the following
   a. **Scale.** Allows you to specify the scale of the movie:
      - **Show all** makes the entire movie visible in the specified area without distortion, while maintaining the original aspect ratio of the movie. Borders may appear on two sides of the movie.
      - **No Border** scales the movie to fill the specified area, without distortion but possibly with some cropping, while maintaining the original aspect ratio of the movie.
      - **Exact Fit** makes the entire movie visible in the specified area without trying to preserve the original aspect ratio. Distortion may occur.
   b. **Auto Play.** Specifies whether the movie begins playing immediately on loading in the browser.
   c. **Loop.** Specifies whether the movie repeats indefinitely or stops when it reaches the last frame.
   d. **Enable Flash Menu.** Gives users a several options for controlling the video.
   e. **Id.** The id attribute specifies a unique identifier which maybe used in CSS styling or DOM manipulation.
   f. **Stylesheet Classes.** A space separated list of CSS classes to apply to the element.
   g. **Advisory Title.** Defines the text that displays when the user mouses over the link.
   h. **Style.** Allows entry of custom CSS style information for the element.

6. Click **OK**. (Click **Cancel** if you decide to exit the dialog box without making changes.)

**Using Movies**

Movies are a good way to make your content more engaging. Movies are generally different from Flash presentations in that movies are larger in file size, and movies cannot contain Flash presentations (Flash presentations are generally smaller in file size, contain much more animation, and can contain movies.)
There are several movie formats that can be used on the Internet. The following are the most common. For each movie format, a plug-in or helper application must be installed on the computer of the user viewing the movie.

- **.avi** is short for audio/video interleaved. Originally developed as a rival to QuickTime format for Windows machines, but is playable on most computers via helpers and plugin. It can use several compression schemes and is becoming increasingly popular. Most digital video cameras shoot in .avi format.

- **.mov** file types are based on the QuickTime (QT) system. It was designed initially for the Mac platform, but is now usable via a plug-in and helper application on most other operating systems. You can load the standard QuickTime player™ from Apple for free as well as get access to a host of resources. QT has some great compression schemes that often make QT files smaller without loss of quality.

- **.mpeg** format takes its name from the developing group (motion Pictures Expert Group). It remains an important web video file type due to the range of compression that can be applied. Unlike .avi and QuickTime, it is not developed for a particular operating system.

- **.wmv** (short for Windows Media Video) is part of Microsoft Windows media format. .wmv files can be downloaded or streamed. Microsoft has tons of resources at http://www.microsoft.com/windows/windowsmedia/default.asp, many of which are free to download.

- **.rm** is the extension for RealVideo® files, the archetype of streamed video files. One of the first and still most popular streamed media format. The basic player can still be downloaded for free at http://www.real.com/.

To add a movie, follow these steps:

1. Position your cursor where you want to insert the movie.


3. On the Movie Properties dialog box, complete the following fields:
   a. **URL.** Specifies a web address of the Movie file. Select the Browse Server button to navigate to the file if it is located in the course or is to be uploaded to the course.
   b. **Auto size.** Automatically creates a display size for the player based on the size of the movie clip.
   c. **Auto play.** Automatically begins to play the movie once the page is loaded.
   d. **Show gotobar.** Looks for markers that have been inserted into the movie file and creates a drop-down table of contents for the file, allowing users to skip to a particular section.
e. **Show statusbar.** Shows users how long the movie has been playing and how much time is left.
f. **Show controls.** Determines which controls are displayed in the window.

**Tip:** The **Show controls** options are checked by default.

4. Click **OK.** (Click **Cancel** if you decide to exit the dialog box without making changes.)

**Google Media™ Tools**

The Google Media™ tools can be used to insert YouTube™ or Picasa™ content into a course environment. YouTube™ videos may be linked or embedded (with associated player). Picasa™ pictures may also be linked or embedded.

**Caution:** ANGEL’s "G" button relies on Google™ open APIs to search YouTube™ for video and Picasa™ for images. If Google™ changes these APIs, the "G" button may fail to function properly. ANGEL has no control over the Google™ APIs.

---

**Note:** The search controls for the Videos tab are identical to the controls offered for the Images tab.

1. **Videos.** Controls for searching YouTube™ for video content. Selected content may be inserted into the HTML editor.
2. **Images.** Controls for search Picasa™ for pictures. Selected pictures may be inserted into the HTML editor.

3. **Find.** Search terms may be entered in this textbox. Terms entered will be used to find matching content.

4. **Sort by.** Select the appropriate option:
   - relevance
   - rating
   - date published
   - most watched

5. **Go.** Click this button to perform a search based on the configured selections.

6. **Media preview.** Media matching the search criteria are displayed in the preview window for each hit. Clicking a preview item opens the related media in a larger window.

7. **embed.** Click this button to insert an embedded media viewer into the HTML editor. This embedded player will be used to view the media.

8. **link.** Click this button to insert a link in the HTML editor. When clicked, the link will open a new window displaying the media.

9. **Pagination.** Results will be displayed in groups of 25. If there are more than 25 results, pagination will be introduced. Each pagination link will link to another group of 25 results.

10. **Cancel.** Click Cancel to close the Google Media window.

**Note:** Media inserted into the HTML editor using the Google Media window will be represented in the HTML window using a placeholder image. This placeholder image will later be replaced with an actual preview of the media when the HTML editor is closed and the content saved.

---

**Working with Forms**

A form is a collection of fields that you use for gathering information from your page. Visitors fill out a form by typing text, clicking radio buttons and checkboxes, and selecting options from drop-down menus. After filling out the form, visitors submit the data they entered, which can be processed in a variety of ways depending on the form handler you set up.

The general steps in creating a form are as follows:

1. Decide what kind of information to collect and then start a form.
2. Add fields to the form.
3. Set up how you want to handle the information you collect from the form.

Form fields are the individual fields on a form that are used to gather information. Each field is identified by a name and value pair. The name is the identifier for the form elements that can be referred by name once the form is submitted. The value field is the information entered by the visitor. For example, if you define a text field named `MyField`, and the visitor enters `Hello World` into the field and submits the form; the name/value pair would be `MyField=hello world`.

- **Text fields.** Use text fields to collect a small amount of text, such as a name, number, or e-mail address.
- **Radio buttons.** Use radio buttons when you want the site visitor to select only one option from a group.
- **Text areas.** Use text areas to collect one or more lines of text, such as a comment or a name in a guest book. This field scrolls to accommodate varying amounts of text.
- **Selection fields.** Use a selection field to present the site visitor with a list of choices. This field is similar to using a group of radio buttons, but takes less space on your form. You can configure a drop-down menu to allow one or multiple selections.
- **Checkboxes.** Use checkboxes for optional items. The site visitor can select or clear the checkbox. They can also select multiple items.
- **Buttons.** Use buttons to let site visitors submit the form after filling it out, clear fields by resetting the form, or run your custom scripts.
After a visitor submits the form, you must collect the data that was entered (the form results) so you can view them, display them to the visitor, or work with them as needed. ANGEL provides a technique that saves the results to a file associated with the lesson item (post.htm in the Associated File Manager for the item). Each time a visitor submits a form, the results are appended to the file. You can then open the file and view the results. You can also access form submissions from the following content items submissions menus: Files, Links, Pages.

**Defining the Form**

Before adding form elements, you must first define the form.

1. Do one of the following:
   - Click the Form icon.
   - On the Form menu, select Form.

2. On the Form dialog box that displays, complete the following fields:

   - **Name.** Type a name for your form.
   - **Action.** Type the name of the form handler.
     
     **Note:** If you are using the ANGEL form handler, type $POST_URL$ into the Action field.
   - **Method.** Select GET or POST (if you are using the ANGEL form handler, select POST):
     - GET passes the form information to the form handler (Action) via the URL. As the total size of a request (URL+params) approaches or exceeds 1 KB, you are well-advised to use POST in any case.
     - POST passes the form information to the form handler (Action) in the body of HTTP request. There is no size limit on the amount of information being sent via POST.

3. Click OK. A red dotted line appears in the HTML Editor. You can now add elements to your form.

**Adding Form Elements**

Forms are composed of the following elements. You can elect to have your audience complete text fields or you can simplify answers and have them click radio buttons and checkboxes.

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✔️ Checkbox</td>
<td>Use checkboxes for optional items. The site visitor can select or clear the checkbox. They can also select multiple items.</td>
</tr>
<tr>
<td>☐ Radio Button</td>
<td>Use radio buttons when you want the site visitor to select only one option from a group.</td>
</tr>
</tbody>
</table>
### Checkboxes

To add a checkbox, follow these steps:

1. Position your cursor where you want the checkbox.
2. On the **Forms** menu, select **Checkbox**. (✓ Checkbox)
3. On the **Checkbox** dialog box, complete the following fields:

   - **Name**: Type a name for your checkbox.
   - **Value**: The value for the box.
   - **Selected**: Select if you want the checkbox to be checked by default.

4. Click **OK**.
5. Type the text you want your audience to see.

### Radio Buttons

To add a radio button, follow these steps:

1. Position your cursor where you want the radio button.
2. On the Forms menu, select Radio Button.

3. On the Radio Button dialog box that displays, complete the following fields:

   a. **Name.** Type a name for your radio button.
   
   b. **Value.** The value for the box.
   
   c. **Selected.** Choose if you want the checkbox to be checked by default.

4. Click OK.

5. Type the text you want your audience to see.

**Text Fields**

To add a text field, follow these steps:

1. Position your cursor where you want the text field.

2. Click the Form menu and select Text Field.

3. On the Text Field dialog box that displays, complete the following fields:

   a. **Name.** Type a name for your text field.
   
   b. **Value.** The value for the box.
   
   c. **Character Width.** Type the width in pixels.
   
   d. **Maximum Characters.** Type the maximum number of characters that can be entered in the field.
   
   e. **Type.** Select Text or Password from the drop-down list.
4. Click OK.

**Text Areas**

To add a text area, follow these steps:

1. Position your cursor where you want the form area.

2. Click the Form menu and select Textarea.

3. On the Textarea dialog box that displays, complete the following fields:

   ![Textarea -- Web Page Dialog](image)

   - **Name.** Type a name for your text area.
   - **Rows.** Type the number of rows wide the field will be.
   - **Columns.** Type the number of columns high the field will be.

4. Click OK.

**Selection Fields**

To add a selection field, follow these steps:

1. Position your cursor where you want the selection field.

2. Click the Form menu and select Selection Field.

3. On the Selection Field dialog box that displays, complete the following fields:
a. **Name.** Type a name for your text area.

b. **Size.** Type the number of lines you want your selection field to have.

c. **Allow multiple selections.** Check if you want your form to allow several options to be selected.

d. **Available options.** Type your option.

e. **Value.** The value for the box.

4. Click **Add.**

5. Other options for selection fields are available:
   - To set a certain option as the default, click the **Set as selected value** button.
   - To delete an option, select the option you want to delete and click **Delete.**
   - To move the selection, click the **Up** or **Down** buttons to move the selection.
   - To modify an option, select the option. Complete your changes in the **Text** and **Value** boxes. Then click **Modify.**

**Buttons**

To add a button, follow these steps:

1. Position your cursor where you want the button.

2. On the **Form** menu, select **Button.**

3. On the **Button** dialog box that displays, complete the following fields:
a. **Name.** Type a name for your button.

b. **Value.** The text to appear on the button face.

c. **Type.** The action to be taken when the button is pressed:
   - **Button.** No default action. A custom script must be used to perform an action when this button type is pressed.
   - **Submit.** Submits the form.
   - **Reset.** Clears the form field.

4. Click **OK.**

**Image Buttons**

To add an image button, follow these steps:

1. Position your cursor where you want the Image button.

2. In the **Form** menu, select **Image Button**.

3. On the **Image Info** tab, complete the following:
a. **URL.** Browse the server for the image or enter a URL.
b. **Short Description.** Describe your button.
c. **Width.** Set your images' width. When a picture is selected, the width is automatically set. You can change it by highlighting the width and entering in the width you want.
d. **Height.** Set your images' height in pixels.
e. **Border.** Set your images' border size. When a picture is selected, the height is automatically set. You can change it by highlighting the height and entering the height you want.
f. **HSpace.** Set the horizontal space around your image. HSpace defines the amount of white space to be inserted to the left and right of an image.
g. **VSpace.** Set the vertical space around your image. VSpace defines the amount of white space to be inserted above and below an image.
h. **Align.** Specifies how to align the image according to surrounding text.
   - **Left.** Aligns the image to be left justified. Text will begin at the top of right of the image.
   - **Abs Bottom.** Aligns the bottom of the first line of text with the bottom of the image.
   - **Abs Middle.** Aligns the top of the first line of text with the middle of the image.
   - **Baseline.** Aligns the bottom of the image with the baseline of the text. The baseline is the line along which the bottom of most letters rest but below which some letters dangle, such as j and y.
   - **Bottom.** Aligns the bottom of the image with the baseline of the line containing the image.
   - **Middle.** Aligns the center of the image with the bottom of the first text line.
   - **Right.** Aligns the image to be right justified. Text will start at the top left of the image.
   - **Text Top.** Aligns the first line of text with the top of the image.
   - **Top.** Aligns the top of the image with the tallest item on the line containing the image.

4. Click the **Advanced** tab.
5. On the **Advanced** tab, complete the following:
a. **Id.** The Id attribute may be used to create an anchor at the start tag of any HTML element (HTML Id attribute).

b. **Language Direction.** Specifies the base direction of directionally neutral text:
   - Left to right
   - Right to left

c. **Language Code.** Specifies the base language of the target URL.

d. **Long Description URL.** Specifies the URL of a document that contains an extended description of the resource.

e. **Stylesheet Classes.** Assigns a class name or set of class names to an element.

f. **Advisory Title.** Defines the text that displays when the user hovers the mouse over the link.

g. **Style.** Allows entry of custom CSS style information for the element.

6. Click **OK**.

**Hidden Fields**

To add a hidden field, follow these steps:

1. Position your cursor where you want the hidden field.

2. Click the **Form** menu and select **Hidden Field**.

3. On the **Hidden Field** dialog box that displays, complete the following.
a. **Name.** Type a name for your hidden field.

b. **Value.** Type the value for the hidden field.

4. Click **OK**.

**Working with the Equation Editor**

The WebEQ Equation Editor has been integrated into the ANGEL HTML editor. It gives editors a way to enter mathematical expressions in a web page, much as the text entry controls and buttons in typical HTML forms give users a way to enter other kinds of information.

The Insert Equation function is used with WebEQ Equation Editor, which can be used to create, save, and view complex mathematical equations in ANGEL. Equations are built up out of mini-templates. These blank templates are small squares that can be filled in.

When the cursor is in a slot, the parent template is faintly outlined in gray. Because many templates can be nested in a single equation, this helps you keep track of where you are.

The WebEQ Equation Editor toolbar includes the following tools. (The table after the figure describes the tools, using the matching letters from the figure.)

```
<table>
<thead>
<tr>
<th>Letter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Layout palette</td>
</tr>
<tr>
<td>B</td>
<td>Accents palette</td>
</tr>
<tr>
<td>C</td>
<td>Fences palette</td>
</tr>
<tr>
<td>D</td>
<td>Trigonometry palette</td>
</tr>
<tr>
<td>E</td>
<td>Calculus palette</td>
</tr>
<tr>
<td>F</td>
<td>Matrices palette</td>
</tr>
<tr>
<td>G</td>
<td>Arrows palette</td>
</tr>
<tr>
<td>H</td>
<td>Operators palette</td>
</tr>
<tr>
<td>I</td>
<td>Comparison operators palette</td>
</tr>
<tr>
<td>J</td>
<td>Set theory palette</td>
</tr>
</tbody>
</table>
```
Inserting Equations

1. To insert an equation, do one of the following:
   - Click the Insert Equation $\Sigma$ icon.
   - On the Insert menu, select Insert Equation $\Sigma$. The Insert Equation dialog box displays.

2. Position your cursor where you want the equation to appear.
3. Click the down arrow to expand the menu of an equation.
4. Select an equation template from the list.
5. Exchange the placeholders for the characters you want by clicking each box and typing the characters.

**Tip:** The squares indicate areas in which you must enter numerical or alphabetical values (no special characters, such as commas or quotation marks). Values must be entered for all squares in an equation. You can use Tab to cycle between empty placeholders.

6. Click OK.

**Note:** You can click Cancel at any time to cancel this action.
**Editing Equations**

To edit an equation, follow these steps:

1. Select the equation and perform one of the following:
   - Click the **Insert Equation** icon.
   - On the **Insert** menu, select **Insert Equation**.
2. Change the placeholders for the characters you want by clicking in each box and typing the characters.
3. Click **OK**.

**Deleting Equations**

To delete an equation, select the equation and press **Delete**.

**Using the Insert Menu**

The Insert menu offers a variety of tools for special use, including the following:

- **Templates**. Choose prebuilt page layouts for your page design.
- **Special Character**. Allows you to add special symbols such as currency or copyright symbols to your page.
- **Universal Keyboard**. Allows you to type in multiple languages.
- **Line**. Allows you to insert a line in your document or table cell.
- **Page break**. Allows you to insert a page break in your page.

**Inserting Templates**

The predefined templates available include the following.

- **Image and Title**. One main image with a title and text that surround the image.
- **Two Columns**. A template that defines two columns, each with a title and some text.
- **Text and Table**. A title with some text and a table.

**Reference:** See "Customizing Content Templates" for details on how to create new templates.

To insert a template, follow these steps:

1. Position your cursor where you want the character in your document.
2. On the **Insert** menu, select **Templates**.
   - The **Content Templates** dialog box displays.
3. Select the template you want to use. The template is automatically inserted into the HTML editor.

**Inserting Special Characters**

To insert a special character, follow these steps:

1. Position your cursor where you want the character in your document.

2. On the **Insert** menu, select **Insert Special Character**. The **Select Special Character** dialog box displays.

3. Click the special character you want. The character is inserted into your page.
Using the Universal Keyboard

With the Universal Keyboard, you can select from several different languages in which to type into the editor window. This function is helpful when you need special characters such as currency symbols or if you want to type a word in its original language.

The empty text box at the top of the Universal Keyboard dialog box is the text editor. Underneath it are the language buttons. Use the blue KB buttons at either end of the language buttons to scroll the list of language buttons forward/backward. On the keyboard, type your text.

To change the language, follow these steps:
1. Position your cursor where you want the character in your document.
2. On the Insert menu, select Universal Keyboard to insert type into your document or specific table cell.
3. In the Universal Keyboard dialog box, select your language by using the scroll buttons and by clicking the appropriate language.

Note: You can click Cancel at any time to cancel this action.

To insert a new language, follow these steps:
1. Change your language in the Universal Keyboard.
2. Type your text by clicking each letter or symbol.
3. Click OK.

Adding Lines

To insert a horizontal line, follow these steps:
1. Position your cursor where you want the line in your page or table cell.
2. Click the Insert menu and select Line.
**Inserting Page Breaks**

To insert a page break (takes effect only when the page is printed), follow these steps:

1. Move your cursor to where you want the page break in your page or table cell.
2. Click the **Insert** menu and select **Page Break**.

---

**Using Other Tools**

In addition to standard tools that are similar to word processing programs, the HTML editor also gives you the following tools:

- **Spellcheck.** Allows you to check large text box entries for misspellings through an easy-to-use interface. In addition, users can add custom words or spellings to their personal dictionary to aid future use of the spell checker tool. The spell checker tool is available throughout ANGEL and is accessible through a visible link found below large text boxes on all editor screens.

- **Source.** Allows you the flexibility to view and fine-tune HTML and css styles; or add Flash object code, insert JavaScript, and insert other advanced code that is unavailable in the WYSIWYG portion of the editor.

- **Document Properties.** Allows you to format your document with settings such as language, colors, background type, author, and copyright.

- **Preview.** Allows you to preview your work before or after saving.

- **Save.** Allows you to save your work.

**Checking the Spelling**

1. To spell check the page, perform one of the following:

   - Click the **Check Spelling** icon.
   - On the **File** menu, select **Check Spelling**.

2. If the program finds a questionable word, a **Spell Checker** dialog box displays. In this dialog box, you are given the option to replace the word, replace all, ignore, ignore all, add, or cancel. Select the option that is applicable.
3. When spell check is complete, click **OK**.

**Viewing the HTML Code**

To view the HTML source code, click **Source**.

To return to the editing mode, click **Source**.

**Previewing the Page**

To preview the page, do the following:

1. On the **File** menu, select **Preview**.

**Saving the Page**

To save your work, do one of the following:

- Click the **Save** button on the lower-left side of the Page editor window.
- On the **File** menu, select **Save**.

You will return to the list of your lesson pages.

**Note:** You can click **Cancel** at any time to cancel this action.

**Customizing Content Templates**

The HTML editor content template can be customized and new templates can be added by modifying the file `AngelRoot/InlineEditor/fcktemplates.asp`. This XML-formatted file provides all the information needed to allow users to preview templates via an image thumbnail before selecting the template. The preview thumbnail image files should be placed in the `AngelRoot/InlineEditor/editor/dialog/fck_template/images/` directory.

**Note:** Customizing the content template requires knowledge of XML and HTML, and requires ANGEL administrator privileges.
To add a new template, follow these steps:

1. Log on to ANGEL with an Administrator account.
2. Click the Administrator Consol button.
3. Click the Application File link.
4. Click the InlineEditor folder.
5. Click Edit link below the fcktemplates.asp file.
6. Copy and paste the following XML (only the bold text) into the fcktemplates.asp file. This should be placed within the top node <Templates...></Templates...> and between the other template nodes:

```
<Templates...>
<Template...
<Description>
</Description>
</Template>
</Templates...>
```

7. Replace the following with your template details:
   - **Template_Title**. The title of the template. This title displays in the Content Template dialog box.
   - **Template_Thumbnail**. The thumbnail image file name. This image displays in the Content Template dialog box.
   - **Template_Description**. The description of the template. This image displays in the Content Template dialog box.
   - **Template_HTML**. The HTML used to build the template when the template is selected from the Content Template dialog box.

8. Click Save.

9. From the InlineEditor folder, click the following folders to navigate to the thumbnail images folder: Editor > Dialog > fck_template > Images.

10. Click the Add Content link.

11. Click Upload Files.

12. Click Browse and navigate to the thumbnail image to be uploaded.

13. Click Upload File.

14. Click Done.

### Customizing Styles

The Styles drop-down menu of the editor can be completely customized. The configuration of this menu is controlled by the file /InlineEditor/fckstyles.asp. This is an XML-formatted file that allows you to specify any number of custom styles, and the particular tags and attribute values to add or modify when a style is selected.

> **Note:** Customizing the styles requires knowledge of XML and HTML, and requires ANGEL Administrator privileges.

To add a new style, follow these steps:

1. Log on to ANGEL with an Administrator account.
2. Click the Administrator Consol button.
3. Click the Application File link.
4. Click the InlineEditor folder.
5. Click Edit link below the fckstyles.asp file.
6. Copy and paste the following XML (only **bold** text) into the fcktemplates.asp file. This should be placed within the top node <Styles...></Styles...> and between the other template nodes:

   ```xml
   <Styles>
     <Style>                                             Begin existing style
       ...
     </Style>                                            End existing style
     <Style name="Style_Name" element="div">
       <Attribute name="class" value="Style_Value" />
       <Attribute name="style" value="Style_Value" />
     </Style>
     ...
   </Styles>
   
   7. Replace the following with your template details:

   - **Style_Name.** The title of the style. This title displays in the Style list.
   - **Style_Value.** The name of the style to apply to the HTML span.
     a. **class.** Reference to a CSS style in the ANGEL theme or a custom CSS page.
     b. **style.** The inline CSS style for the style.
   
   8. Click Save.

**Shortcut Keys**

If you frequently use the HTML editor, you will want to learn a few shortcut keys.

<table>
<thead>
<tr>
<th>Keys</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl-A</td>
<td>Select all text/objects in the editor.</td>
</tr>
<tr>
<td>Ctrl-B</td>
<td>Bold the selected text</td>
</tr>
<tr>
<td>Ctrl-C</td>
<td>Copy the selected text/objects to the clipboard.</td>
</tr>
<tr>
<td>Ctrl-I</td>
<td>Italicize the selected text.</td>
</tr>
<tr>
<td>Ctrl-K</td>
<td>Create a hyperlink from the selected text.</td>
</tr>
<tr>
<td>Ctrl-U</td>
<td>Underline the selected text.</td>
</tr>
<tr>
<td>Ctrl-V</td>
<td>Paste the selected text/objects from the clipboard.</td>
</tr>
<tr>
<td>Ctrl-X</td>
<td>Cut the selected text/objects to the clipboard.</td>
</tr>
<tr>
<td>Ctrl-Z</td>
<td>Undo the last command/action.</td>
</tr>
<tr>
<td>Shift-Enter</td>
<td>Insert a line break (&lt;BR&gt; html tag)</td>
</tr>
</tbody>
</table>